РЕКЛАМА
ИНФОРМАЦИЯ
ПОЛЕЗНЫЕ ССЫЛКИ
Thecus N12000: обзор NAS на 12 дисков

Rambler's Top100 Рейтинг@Mail.ru

СЕТИ

Thecus N12000: обзор NAS на 12 дисков
Краткое содержание статьи: Представитель флагманской линейки сетевых хранилищ уровня предприятия – Thecus N12000 – попал сегодня в тестовую лабораторию THG. Эта линейка состоит из двух наиболее производительных устройств: N12000 и N16000 на двенадцать, и шестнадцать дисков, соответственно. Кроме производительности эту линейку отличают более продуманная аппаратная платформа и дополнительные программные функции, о которых вы узнаете, прочитав сегодняшний обзор на THG.ru.

Thecus N12000: обзор NAS на 12 дисков


Редакция THG,  20 сентября 2011
Назад
Вы читаете страницу 4 из 7
1 2 3 4 5 6 7
Далее


Thecus N12000 | Стекирование, агрегирование, резервирование

При исчерпании дискового пространства одного хранилища уровня предприятия может быть произведено его расширение путём создания стека из нескольких устройство Thecus. Для указанной цели мы запросили второе хранилище – N8800+, которое мы использовали в качестве подчинённого устройства в стеке. Весь процесс объединения в стек можно разделить на две стадии: создание целевого тома iSCSI и подключение его к мастеру стека. Создание целевого тома iSCSI производится на подчинённом хранилище с помощью пункта "Распределение пространства" группы "Хранилище" веб-интерфейса, где требуется указать имя ресурса и его объём. Для предотвращения несанкционированных подключений может быть использована CHAP-аутентификация.

Thecus N12000: тест и обзор

Thecus N12000: тест и обзор

Подключение ранее созданного целевого тома производится на мастере стека с помощью пункта "Стекирование" группы "Хранилище", для чего требуется указать IP-адрес второго устройства и произвести обнаружение доступных на нём ресурсов iSCSI. Чтобы новое дисковое пространство стало доступным пользователям, необходимо произвести его форматирование.

Thecus N12000: тест и обзор

Thecus N12000: тест и обзор

Thecus N12000: тест и обзор

Ресурсы подчинённых устройств стека будут доступны пользователям по всем основным протоколам, включая SMB и FTP, и будут видимы в отдельном каталоге.

Thecus N12000: тест и обзор

В качестве мастера стека выбирают обычно самое мощное и быстрое устройство, которым в нашем примере являлось хранилище Thecus N12000, однако технически не запрещено любому из хранилищ выполнять функции главного устройства в стеке. Стоит отметить, что создание целевого тома iSCSI производится в пункте "iSCSI" группы "Хранилище" веб-интерфейса N12000.

Thecus N12000: тест и обзор

Обсуждаемая схема стекирования скрывает от пользователя логику работу стека хранилищ, однако активно использует существующую сетевую инфраструктуру, что с одной стороны, позволяет размещать хранилища в географически удалённых ЦОД, но с другой, нагрузка на сеть существенно возрастает, так как данные от подчинённого устройства к пользователю и обратно передаются через стекообразующее устройство. Нивелировать указанную проблему можно путём использования 10 GE сетевых карт, опционально устанавливаемых в промышленные хранилища Thecus.

При нехватке полосы пропускания одного интерфейса Gigabit Ethernet, может производиться их агрегирование с целью образования логического порта большей пропускной способности. Thecus N12000 предоставляет администратору выбор одного из шести способов агрегации, некоторые из которых требуют дополнительной настройки со стороны коммутатора.

Thecus N12000: тест и обзор

Мы успешно подключили Thecus N12000 к коммутатору Cisco 3750 и выбрали схему балансировки 802.3ad. Основные параметры портов коммутатора представлены ниже.

interface GigabitEthernet1/0/11

switchport

switchport access vlan 2

switchport mode access

channel-group 2 mode on

interface GigabitEthernet1/0/12

switchport

switchport access vlan 2

switchport mode access

channel-group 2 mode on

interface Port-channel2

switchport

switchport access vlan 2

switchportmodeaccess

Внедрение протокола 802.3ad позволяет не только выполнять агрегирование каналов с целью повышения доступной полосы пропускания, но и предоставлять функции резервирования, позволяя защититься от падения физического канала передачи данных, порта коммутатора или сетевого интерфейса самого хранилища. При использовании со стороны сетевого оборудования стека коммутаторов (например, Cisco Catalyst 3750) или технологий, подобных Cisco VSS, обсуждаемая схема позволяет защититься также и от падения отдельного коммутатора, к которому подключается Thecus N12000.

Стоит отметить, что для использования VSS потребуются два коммутатора Cisco Catalyst 6500 с супервизорами Virtual Switching Supervisor 720-10GE, что далеко выходит за рамки данного обзора.Thecus N12000 и N16000 имеют собственные механизмы резервирования, повышения доступности устройств; позволяя защититься от падения целого хранилища, крушения дискового массива, а также потери сетевого подключения основного хранилища. Обсуждаемые механизмы позволяют объединить два устройства в виртуальную группу, которая разделяет один виртуальный IP-адрес. Хранилища в такой группе работают по схеме Active/Standby, то есть обеспечивается только резервирование устройств, но не балансировка нагрузки на них. Конечно, если хранилища используются исключительно для предоставления данных пользователям без права записи на них, то балансировка и резервирование могут быть обеспечены внешними средствами, например, Cisco SLB (Server Load Balancing), однако мы отвлеклись. Картинка ниже демонстрирует типовую схему работы системы повышения доступности Thecus.

Thecus N12000: тест и обзор

Настройка активного и резервного хранилища производится с помощью пункта "High-Availability" группы "Сеть и сервисы" веб-интерфейса, имеющего четыре вкладки: "Settings", "HeartBeats", "Status" и "Readme". Вкладка "Settings" позволяет указать IP-адреса физического порта LAN1 устройств, а также адрес виртуального сервера. Параметры проверки доступности второго устройства группы размещены во вкладке "HeartBeats". Вкладки "Status" и "Readme" отображают информацию о текущем состоянии HA-системы и справочную информацию, соответственно.

Thecus N12000: тест и обзор

Thecus N12000: тест и обзор

Вкладка "HeartBeats" позволяет указать, стоит ли осуществлять автоматический переход резервного устройства в состояние "Standby" при возобновлении работы основного хранилища. К сожалению, возможности ручного перехода между статусами устройства пользователю не предоставлено. На наш взгляд, это было бы очень полезно при проведении плановых работ для сокращения времени простоя группы.

Стоит рассказать о ещё двух возможностях резервирования, предлагаемых Thecus N12000. Речь идёт о пунктах "RsyncTarget" и "Резервное копирование DualDOM" группы "Резервное копирование". На последнем пункте хотелось бы остановиться подробнее. "Резервное копирование DualDOM" сохраняет до пяти копий конфигурации системы в ручном или автоматическом режимах, что позволяет воспользоваться сохранённой копией при невозможности загрузить систему в штатном режиме.

Thecus N12000: тест и обзор

Thecus N12000: тест и обзор

Подключимся теперь к Thecus N12000 по протоколу SNMP.
Назад
Вы читаете страницу 4 из 7
1 2 3 4 5 6 7
Далее


СОДЕРЖАНИЕ

Отзывы о Thecus N12000 в Клубе экспертов THG [ 8 отзывов] Отзывы о Thecus N12000 в Клубе экспертов THG [ 8 отзывов]


РЕКЛАМА
РЕКОМЕНДУЕМ ПРОЧЕСТЬ!

История мейнфреймов: от Harvard Mark I до System z10 EC
Верите вы или нет, но были времена, когда компьютеры занимали целые комнаты. Сегодня вы работаете за небольшим персональным компьютером, но когда-то о таком можно было только мечтать. Предлагаем окунуться в историю и познакомиться с самыми знаковыми мейнфреймами за последние десятилетия.

Пятнадцать процессоров Intel x86, вошедших в историю
Компания Intel выпустила за годы существования немало процессоров x86, начиная с эпохи расцвета ПК, но не все из них оставили незабываемый след в истории. В нашей первой статье цикла мы рассмотрим пятнадцать наиболее любопытных и памятных процессоров Intel, от 8086 до Core 2 Duo.

ССЫЛКИ